XR600C

This forum is for talking about all types of Peavey mixers.
Jim Duckett
New Member
Posts: 2
Joined: Mon Apr 25, 2011 8:51 am

XR600C

Postby Jim Duckett » Mon Apr 25, 2011 9:03 am

I have a XR600C which I bought used, the only thing wrong with it at the time was XLR on channnel 1 needed to be re-soldered.
Lately though it has needed to warm up for a minimum of half-hour before everything works fine, then this past Sat. night all inputs were acting broken, like there is a bad connection between any and all inputs and the line out to speakers. Any help would be greatly appreciated. Thanks,
Jim Duckett.

Marty McCann
Member
Posts: 4141
Joined: Mon Oct 27, 2008 3:50 pm

Re: XR600C

Postby Marty McCann » Mon Apr 25, 2011 10:02 am

Jim Duckett wrote:I have a XR600C which I bought used, the only thing wrong with it at the time was XLR on channnel 1 needed to be re-soldered.
Lately though it has needed to warm up for a minimum of half-hour before everything works fine, then this past Sat. night all inputs were acting broken, like there is a bad connection between any and all inputs and the line out to speakers. Any help would be greatly appreciated. Thanks,
Jim Duckett.


I do not know about the warm-up thing as this should not happen

You problem may lie with the switching jacks on the front panel for the EQ and Pwr Amp Inputs. Take a short shielded cable and connect directly from the jack labeled MAIN OUT to the one labeled PWR AMP IN. \

Does it work now? If so it is one (or both) of the switching jacks. Sometimes they can be re-tensioned with a Dental Pik, or you can simply leave two short cables inserted between these jacks.

Jim Duckett
New Member
Posts: 2
Joined: Mon Apr 25, 2011 8:51 am

Re: XR600C

Postby Jim Duckett » Mon Apr 25, 2011 12:10 pm

Taking the shielded cable from Main OUT to Power Amp IN worked great. I'm going to leave it that way for now, until I have more time to re-tension the switching jacks. Thank You Marty McCann :D

Marty McCann
Member
Posts: 4141
Joined: Mon Oct 27, 2008 3:50 pm

Re: XR600C

Postby Marty McCann » Mon Apr 25, 2011 4:01 pm

Jim Duckett wrote:Taking the shielded cable from Main OUT to Power Amp IN worked great. I'm going to leave it that way for now, until I have more time to re-tension the switching jacks. Thank You Marty McCann :D


Yes, it is good that it works, but you will not have a functioning EQ. You can use one short shielded cable for the Main OUT to the EQ IN and another from the EQ OUT to the PWR AMP IN.

All should then work!


Return to “Mixers”

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest