peavey musican 400

This forum is for discussions on all kinds of Peavey bass amplifiers.
Post Reply
plen
New Member
Posts: 6
Joined: Sat Feb 08, 2020 6:40 pm

peavey musican 400

Post by plen » Sat Feb 08, 2020 6:53 pm

i bought a peavey musican 400 head and a 4x12 marshall cab. i bought it for the4 marshall cab. my son played the amp and i liked it. it made funny noises. the next time i turned it on it blew the fuse. i changed the 15a fuse and put a 4amp fuse in. the amp wont come on and makes a putting sound from the transformer. the pilot light keeps going off and on. could this be a bac transformer or could it be something else.

thanks.

User avatar
Enzo
Member
Posts: 8751
Joined: Fri Sep 12, 2008 10:24 pm
Location: Lansing, Michigan

Re: peavey musican 400

Post by Enzo » Mon Feb 10, 2020 3:45 pm

Anything is possible, but "bad transformer" is just about always the very last thing on the list.

Look at the schematic, the fuse has a series thermal breaker on teh heat sink. I suspect that is tripping. And as it is self-resetting, it resets itself, then trips again...over and over.

First suspects are shorted output transistors.

plen
New Member
Posts: 6
Joined: Sat Feb 08, 2020 6:40 pm

Re: peavey musican 400

Post by plen » Mon Feb 10, 2020 3:52 pm

enzo thanks for the reply. is there 2 of these amps. mine is the series 400.

plen
New Member
Posts: 6
Joined: Sat Feb 08, 2020 6:40 pm

Re: peavey musican 400

Post by plen » Wed Feb 12, 2020 2:26 pm

does anyone know substitutes for the output transistors.

User avatar
Enzo
Member
Posts: 8751
Joined: Fri Sep 12, 2008 10:24 pm
Location: Lansing, Michigan

Re: peavey musican 400

Post by Enzo » Wed Feb 12, 2020 4:55 pm

Peavey does, and they publish a cross reference. See below
PV Semi Cross Ref.pdf
(96.59 KiB) Downloaded 9 times

plen
New Member
Posts: 6
Joined: Sat Feb 08, 2020 6:40 pm

Re: peavey musican 400

Post by plen » Thu Feb 13, 2020 7:11 pm

i have got a peak dca55 meter. can i test the output transistors in the amp wired up.

plen
New Member
Posts: 6
Joined: Sat Feb 08, 2020 6:40 pm

Re: peavey musican 400

Post by plen » Fri Feb 14, 2020 7:39 pm

i just took the output transistors and tested them. leakage is 0.000ma on all of them. hfe is 17 9 21 21 16 19 7 19

User avatar
Enzo
Member
Posts: 8751
Joined: Fri Sep 12, 2008 10:24 pm
Location: Lansing, Michigan

Re: peavey musican 400

Post by Enzo » Sat Feb 15, 2020 7:07 am

OK, there will be some wires from the transformer to the main board, probably red, with a molex connector. (White plastic connector that disconnects from the board) Unplug that connector so the transformer wires are hanging in the air. Now turn on the power switch. Does it still cycle off and on? I realize there will be no amplifier function this way.

plen
New Member
Posts: 6
Joined: Sat Feb 08, 2020 6:40 pm

Re: peavey musican 400

Post by plen » Sun Feb 16, 2020 9:11 am

enzo i cant try that at the minute as when i turned it on the 4a fuze was blown. that is the second one. it did not blow them right away. it was after it was turned on a few times. i just put in a 2a fuse and it blew right away. i will try to get 4a fuses tomorrow. i can see 2 white connectors. each has three wires. two of the wires on each white connector are going to the big capacitors and one wire from each looks like they are going to the transformer. one wire is black and the other is blue.

thanks peter.

User avatar
Enzo
Member
Posts: 8751
Joined: Fri Sep 12, 2008 10:24 pm
Location: Lansing, Michigan

Re: peavey musican 400

Post by Enzo » Sun Feb 16, 2020 11:41 am

Black and blue are probably the mains connection. I could be wrong.

Look up "light bulb limiter", it is simple. Make one and use it. We don'tt need to be blowing lots of fuses.

Post Reply